packagegroup-agl-demo: remove python-curses
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo.bb
index 9ba99fa..5f82f09 100644 (file)
@@ -17,16 +17,16 @@ MOST_DRIVERS ??= " \
     most \
     "
 # These boards use different kernels - needs to be checked
-MOST_DRIVERS_dra7xx-evm ?= ""
 MOST_DRIVERS_dragonboard-410c ?= ""
+MOST_DRIVERS_cyclone5 ?= ""
 
 
 # HVAC dependencies
 ###################
-LIN_DRIVERS ??= " sllin"
+LIN_DRIVERS ??= " sllin sllin-virtual"
 # These boards use different kernels - needs to be checked
-LIN_DRIVERS_dra7xx-evm ?= ""
-LIN_DRIVERS_dragonboard-410c ?= ""
+LIN_DRIVERS_dra7xx-evm ?= "sllin-virtual"
+LIN_DRIVERS_dragonboard-410c ?= "sllin-virtual"
 
 # UNICENS service
 UNICENS ?= " \
@@ -36,11 +36,11 @@ UNICENS ?= " \
     "
 
 # Hook for demo platform configuration
-# ATM, only used to disable btwilink module on M3ULCB + Kingfisher by default,
+# ATM, only used to disable btwilink module on [MH]3ULCB + Kingfisher by default,
 # setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
 DEMO_ENABLE_BTWILINK ?= ""
 DEMO_PLATFORM_CONF = ""
-DEMO_PLATFORM_CONF_append_m3ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
+DEMO_PLATFORM_CONF_append_ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
 
 SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
     'packagegroup-agl-smartdevicelink', '', d)}"
@@ -50,7 +50,7 @@ SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
 # AUDIO-OLD = "audiomanager"
 
 RDEPENDS_${PN} += "\
-    udisks \
+    udisks2 \
     ${SMARTDEVICELINK} \
     "
 
@@ -60,10 +60,10 @@ TTF_FONTS = " \
     ttf-dejavu-sans \
     ttf-dejavu-sans-mono \
     ttf-dejavu-serif \
+    ttf-noto-emoji-color \
     source-han-sans-cn-fonts \
     source-han-sans-jp-fonts \
     source-han-sans-tw-fonts \
-    noto-emoji \
     "
 
 
@@ -72,7 +72,6 @@ RDEPENDS_${PN} += " \
     linux-firmware-ralink \
     can-utils \
     iproute2 \
-    python-curses \
     dhcp-client \
     ${UNICENS} \
     ${MOST_DRIVERS} \