Changes to support the switch to pipewire
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
index 9deaea2..9039d47 100755 (executable)
@@ -41,7 +41,6 @@ AGL_APPS = " \
     dashboard \
     hvac \
     mediaplayer \
-    virtual/mixer  \
     virtual/navigation \
     phone \
     poiapp \
@@ -51,6 +50,10 @@ AGL_APPS = " \
     agl-service-signal-composer \
     low-can-demo \
     "
+#
+# TODO: fix mixer for pipewire    virtual/mixer  \
+#
+
 
 AGL_APIS = " \
     libnaviapi-agl \
@@ -61,6 +64,17 @@ QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qt
 # mapviewer and mapviewer-demo are required for AGL cluster demo
 MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", " mapviewer mapviewer-demo", "",d)}"
 
+# Preload navigation maps and poi API key for demo if requested
+DEMO_MAPS_LOCALE ?= "uk"
+DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " navigation-maps-${DEMO_MAPS_LOCALE} poiapp-api-key", "",d)}"
+
+# Hook for demo platform configuration
+# ATM, only used to disable btwilink module on M3ULCB + Kingfisher by default,
+# setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
+DEMO_ENABLE_BTWILINK ?= ""
+DEMO_PLATFORM_CONF = ""
+DEMO_PLATFORM_CONF_append_m3ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
+
 RDEPENDS_${PN}_append = " \
     qtquickcontrols2-agl \
     qtquickcontrols2-agl-style \
@@ -70,6 +84,6 @@ RDEPENDS_${PN}_append = " \
     ${AGL_APIS} \
     ${QTAGLEXTRAS} \
     ${MAPVIEWER} \
+    ${DEMO_PRELOAD} \
+    ${DEMO_PLATFORM_CONF} \
     "
-
-