packagegroups: add messaging application to AGL_APPS
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
index 72f2290..8a7b549 100644 (file)
@@ -12,7 +12,83 @@ PACKAGES = "\
 ALLOW_EMPTY_${PN} = "1"
 
 RDEPENDS_${PN} += "\
-    packagegroup-agl-appfw \
-    hvacplugin \
-    homescreen \
+    packagegroup-agl-image-ivi \
+    "
+
+RDEPENDS_${PN} += "\
+    packagegroup-agl-profile-graphical-qt5 \
+    packagegroup-agl-demo \
+    "
+
+MOST_DRIVERS = " \
+    most \
+    "
+MOST_DRIVERS_append_m3ulcb = " sllin"
+
+# HVAC dependencies depend on drivers above
+MOST_HVAC = " "
+MOST_HVAC_append = " \
+    ${MOST_DRIVERS} \
+    unicens-config \
+    agl-service-unicens \
+    agl-service-unicens-controller \
+    "
+
+# @Chris: This needs to be checked!
+MOST_HVAC_dra7xx-evm = ""
+MOST_HVAC_dragonboard-410c = ""
+
+AGL_APPS = " \
+    dashboard \
+    hvac \
+    mediaplayer \
+    virtual/navigation \
+    phone \
+    poiapp \
+    radio \
+    settings \
+    messaging \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'taskmanager' , '', d)} \
+    high-level-viwi-service \
+    agl-service-signal-composer \
+    low-can-demo \
+    virtual/mixer \
+    "
+
+AGL_APIS = " \
+    libnaviapi-agl \
+    "
+
+QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
+
+# Cluster demo support.
+# ATM mapviewer is required for navigation map viewing when doing cluster
+# demos with the older navigation application.
+MAPVIEWER = "${@bb.utils.contains("PREFERRED_PROVIDER_virtual/navigation", "navigation", "mapviewer", "",d)}"
+CLUSTER_SUPPORT = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", "${MAPVIEWER} cluster-demo-network-config", "",d)}"
+
+# Preload poi API key for demo if requested, and potentially maps for older
+# navigation application if it is configured.
+DEMO_MAPS_LOCALE ?= "uk"
+DEMO_PRELOAD_MAPS = "${@bb.utils.contains("PREFERRED_PROVIDER_virtual/navigation", "navigation", " navigation-maps-${DEMO_MAPS_LOCALE}", "",d)}"
+DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} poiapp-api-key", "",d)}"
+
+# Hook for demo platform configuration
+# ATM, only used to disable btwilink module on M3ULCB + Kingfisher by default,
+# setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
+DEMO_ENABLE_BTWILINK ?= ""
+DEMO_PLATFORM_CONF = ""
+DEMO_PLATFORM_CONF_append_m3ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
+
+RDEPENDS_${PN}_append = " \
+    qtquickcontrols2-agl \
+    qtquickcontrols2-agl-style \
+    linux-firmware-ralink \
+    ${MOST_HVAC} \
+    ${AGL_APPS} \
+    ${AGL_APIS} \
+    ${QTAGLEXTRAS} \
+    ${CLUSTER_SUPPORT} \
+    ${DEMO_PRELOAD} \
+    ${DEMO_PLATFORM_CONF} \
     "