packagegroups: add messaging application to AGL_APPS
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
old mode 100755 (executable)
new mode 100644 (file)
index 40e4d3c..8a7b549
@@ -31,6 +31,7 @@ MOST_HVAC_append = " \
     ${MOST_DRIVERS} \
     unicens-config \
     agl-service-unicens \
+    agl-service-unicens-controller \
     "
 
 # @Chris: This needs to be checked!
@@ -41,15 +42,17 @@ AGL_APPS = " \
     dashboard \
     hvac \
     mediaplayer \
-    virtual/mixer  \
     virtual/navigation \
     phone \
     poiapp \
     radio \
     settings \
+    messaging \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'taskmanager' , '', d)} \
     high-level-viwi-service \
     agl-service-signal-composer \
     low-can-demo \
+    virtual/mixer \
     "
 
 AGL_APIS = " \
@@ -58,12 +61,24 @@ AGL_APIS = " \
 
 QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
 
-# mapviewer and mapviewer-demo are required for AGL cluster demo
-MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", " mapviewer mapviewer-demo", "",d)}"
+# Cluster demo support.
+# ATM mapviewer is required for navigation map viewing when doing cluster
+# demos with the older navigation application.
+MAPVIEWER = "${@bb.utils.contains("PREFERRED_PROVIDER_virtual/navigation", "navigation", "mapviewer", "",d)}"
+CLUSTER_SUPPORT = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", "${MAPVIEWER} cluster-demo-network-config", "",d)}"
 
-# Preload navigation maps and poi API key for demo if requested
+# Preload poi API key for demo if requested, and potentially maps for older
+# navigation application if it is configured.
 DEMO_MAPS_LOCALE ?= "uk"
-DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " navigation-maps-${DEMO_MAPS_LOCALE} poiapp-api-key", "",d)}"
+DEMO_PRELOAD_MAPS = "${@bb.utils.contains("PREFERRED_PROVIDER_virtual/navigation", "navigation", " navigation-maps-${DEMO_MAPS_LOCALE}", "",d)}"
+DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} poiapp-api-key", "",d)}"
+
+# Hook for demo platform configuration
+# ATM, only used to disable btwilink module on M3ULCB + Kingfisher by default,
+# setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
+DEMO_ENABLE_BTWILINK ?= ""
+DEMO_PLATFORM_CONF = ""
+DEMO_PLATFORM_CONF_append_m3ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
 
 RDEPENDS_${PN}_append = " \
     qtquickcontrols2-agl \
@@ -73,8 +88,7 @@ RDEPENDS_${PN}_append = " \
     ${AGL_APPS} \
     ${AGL_APIS} \
     ${QTAGLEXTRAS} \
-    ${MAPVIEWER} \
+    ${CLUSTER_SUPPORT} \
     ${DEMO_PRELOAD} \
+    ${DEMO_PLATFORM_CONF} \
     "
-
-