Widget packaging rework
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
index 9f7524a..61b76a5 100644 (file)
@@ -5,8 +5,10 @@ LICENSE = "MIT"
 
 inherit packagegroup
 
+PROVIDES = "${PACKAGES}"
 PACKAGES = "\
     packagegroup-agl-demo-platform \
+    packagegroup-agl-demo-platform-devel \
     "
 
 ALLOW_EMPTY_${PN} = "1"
@@ -17,34 +19,10 @@ RDEPENDS_${PN} += "\
 
 RDEPENDS_${PN} += "\
     packagegroup-agl-profile-graphical-qt5 \
+    packagegroup-hmi-framework \
     packagegroup-agl-demo \
     "
 
-# MOST out-of-tree kernel drivers
-#################################
-MOST_DRIVERS ??= " \
-    most \
-    "
-# These boards use different kernels - needs to be checked
-MOST_DRIVERS_dra7xx-evm ?= ""
-MOST_DRIVERS_dragonboard-410c ?= ""
-
-
-# HVAC dependencies
-###################
-LIN_DRIVERS ??= " sllin"
-# These boards use different kernels - needs to be checked
-LIN_DRIVERS_dra7xx-evm ?= ""
-LIN_DRIVERS_dragonboard-410c ?= ""
-
-# UNICENS service
-UNICENS ?= " \
-    unicens-config \
-    agl-service-unicens \
-    agl-service-unicens-controller \
-    "
-
-
 AGL_APPS = " \
     dashboard \
     hvac \
@@ -55,44 +33,70 @@ AGL_APPS = " \
     radio \
     settings \
     messaging \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'taskmanager' , '', d)} \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
-    high-level-viwi-service \
-    agl-service-signal-composer \
     low-can-demo \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'taskmanager' , '', d)} \
     virtual/mixer \
     "
 
 QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
+QTAGLEXTRAS_append = " libqtappfw"
+
+# add support for websocket in Qt and QML
+QTAGLEXTRAS_append = " qtwebsockets qtwebsockets-qmlplugins"
+#PREFERRED_PROVIDER_virtual/webruntime = "web-runtime"
 
 # Cluster demo support.
 # ATM no cluster map viewer is supported with the older navigation application.
 MAPVIEWER = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "ondemandnavi", "tbtnavi", "",d)}"
-CLUSTER_SUPPORT = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", "${MAPVIEWER} cluster-demo-network-config", "",d)}"
+CLUSTER_SUPPORT_PACKAGES = " \
+       ${MAPVIEWER} \
+       cluster-demo-network-config \
+       cluster-lin-bridging-config \
+       cluster-demo-simulator \
+"
+CLUSTER_SUPPORT = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", "${CLUSTER_SUPPORT_PACKAGES}", "",d)}"
+
+DEMO_UNIT_CONF ?= ""
+# Hook for demo platform configuration
+# ATM used for:
+# 1) Adding udev configuration and scripts for supporting USB attached
+#    I2C devices for RTC and HVAC LED support.
+DEMO_UNIT_CONF += " demo-i2c-udev-conf "
 
 # Preload poi API key for demo if requested, and potentially maps for older
 # navigation application if it is configured.
 DEMO_MAPS_LOCALE ?= "uk"
 DEMO_PRELOAD_MAPS = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "navigation", " navigation-maps-${DEMO_MAPS_LOCALE}", "",d)}"
-DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} poiapp-api-key", "",d)}"
 
-# Hook for demo platform configuration
-# ATM, only used to disable btwilink module on M3ULCB + Kingfisher by default,
-# setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
-DEMO_ENABLE_BTWILINK ?= ""
-DEMO_PLATFORM_CONF = ""
-DEMO_PLATFORM_CONF_append_m3ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
+# Preload only if agl-demo-preload is set
+DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
 
 RDEPENDS_${PN}_append = " \
     qtquickcontrols2-agl \
     qtquickcontrols2-agl-style \
-    linux-firmware-ralink \
-    ${UNICENS} \
-    ${MOST_DRIVERS} \
-    ${LIN_DRIVERS} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
     ${AGL_APPS} \
     ${QTAGLEXTRAS} \
     ${CLUSTER_SUPPORT} \
     ${DEMO_PRELOAD} \
-    ${DEMO_PLATFORM_CONF} \
+    "
+
+# NOTE: Currently no coverage versions for the application widgets,
+#       they should be added here when available.
+#       Also, the navigation and mixer debug widgets are currently
+#       specified explicitly, as there's no simple way to derive their
+#       names from the virtual/ RPROVIDES at present.
+RDEPENDS_${PN}-devel = " \
+    packagegroup-hmi-framework-devel \
+    dashboard-dbg \
+    hvac-dbg \
+    mediaplayer-dbg \
+    mixer-dbg \
+    phone-dbg \
+    ondemandnavi-dbg \
+    poiapp-dbg \
+    radio-dbg \
+    settings-dbg \
+    messaging-dbg \
+    taskmanager-dbg \
     "