html5-mediaplayer: create recipe and add to html5 demo
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-html5.bb
index 9092b18..a963722 100644 (file)
@@ -1,5 +1,5 @@
-SUMMARY = "The software for DEMO platform of AGL IVI profile"
-DESCRIPTION = "A set of packages belong to AGL Demo Platform"
+SUMMARY = "The software for DEMO platform of AGL HTML5 profile"
+DESCRIPTION = "Packages required to demo the HTML5 profile and sample web apps"
 
 LICENSE = "MIT"
 
@@ -13,14 +13,19 @@ ALLOW_EMPTY_${PN} = "1"
 
 RDEPENDS_${PN} += "\
     packagegroup-agl-image-ivi \
+    packagegroup-agl-profile-graphical-html5 \
+    packagegroup-agl-demo \
     "
 
-# add packages for demo platform (include demo apps) here
-RDEPENDS_${PN} += " \
-    packagegroup-agl-demo \
+AGL_APPS = " \
+    html5-homescreen \
+    html5-launcher \
+    html5-hvac \
+    html5-settings \
+    html5-mixer \
+    html5-mediaplayer \
     "
 
-# add packages for OpenIVI-HTML5 demo
-RDEPENDS_${PN} += " \
-    openivi-html5 \
+RDEPENDS_${PN}_append = " \
+    ${AGL_APPS} \
     "