agl-demo-control-panel: add recipe and image
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-ivi-demo-control-panel.bb
diff --git a/recipes-platform/images/agl-ivi-demo-control-panel.bb b/recipes-platform/images/agl-ivi-demo-control-panel.bb
new file mode 100644 (file)
index 0000000..21785ca
--- /dev/null
@@ -0,0 +1,27 @@
+require recipes-platform/images/agl-image-weston.bb
+
+SUMMARY = "AGL demo control panel image"
+
+IMAGE_FEATURES += "splash package-management ssh-server-openssh"
+
+# NOTE: The client key and certificate in kuksa-certificates-agl-client
+#       seem required by kuksa-client at the moment even though client
+#       certification has been deprecated upstream, this needs further
+#       investigation so it can be dropped from the image.
+#   
+IMAGE_KUKSA_PACKAGES = " \
+    kuksa-client \
+    kuksa-certificates-agl-ca \
+    kuksa-certificates-agl-client \
+"
+
+IMAGE_INSTALL += "\
+    packagegroup-agl-networking \
+    weston-ini-conf-landscape \
+    weston-agl-driver-conf \
+    ${IMAGE_KUKSA_PACKAGES} \
+    agl-demo-control-panel \
+    qtwayland \
+    qtwayland-plugins \
+    qtwayland-qmlplugins \
+"