Remove systemd user session and clean up packagegroups and images
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-image-ivi-crosssdk.bb
index 2f722b2..be00883 100644 (file)
@@ -1,20 +1,11 @@
-require recipes-platform/images/agl-image-minimal-crosssdk.inc
+require agl-image-ivi.bb
 
-require recipes-platform/images/agl-image-minimal.inc
+SUMMARY = "Cross SDK of minimal AGL Distribution for IVI profile"
 
-IMAGE_INSTALL:append = "\
-    packagegroup-agl-image-ivi \
-    packagegroup-agl-ivi-services \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'packagegroup-pipewire', '', d)} \
-    can-utils \
-    iproute2 \
-    "
+DESCRIPTION = "SDK image for minimal AGL Distribution for IVI profile. \
+It includes the full toolchain, plus development headers and libraries \
+to form a standalone cross SDK."
 
-IMAGE_FEATURES += "splash package-management ssh-server-openssh"
+inherit agl-crosssdk
 
-inherit populate_sdk
-
-# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
-# Both exec "createrepo" on the same directory, and so one of them
-# can failed (randomly).
-addtask do_populate_sdk after do_rootfs
+require agl-ivi-crosssdk.inc