3rd part of the layer/profile rework [2/2]
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
old mode 100644 (file)
new mode 100755 (executable)
index c4465e1..eac7ea2
@@ -9,7 +9,7 @@ require agl-demo-platform.bb
 LICENSE = "MIT"
 
 IMAGE_FEATURES_append = " dev-pkgs"
-IMAGE_INSTALL_append = " kernel-dev"
+IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
 
 inherit populate_sdk populate_sdk_qt5
 
@@ -17,3 +17,40 @@ inherit populate_sdk populate_sdk_qt5
 # Both exec "createrepo" on the same directory, and so one of them
 # can failed (randomly).
 addtask do_populate_sdk after do_rootfs
+
+# native tools to support Chromium build inside SDK (SPEC-942)
+TOOLCHAIN_HOST_TASK += " \
+    nativesdk-gn \
+    nativesdk-ninja \
+    nativesdk-gperf \
+    nativesdk-zlib \
+    nativesdk-xz \
+    nativesdk-nspr-dev \
+    nativesdk-nss-dev \
+    nativesdk-lua \
+    "
+
+# required dependencies for Chromium build inside SDK (SPEC-942)
+TOOLCHAIN_TARGET_TASK += " \
+    pciutils-dev \
+    pulseaudio-dev \
+    cairo-dev \
+    nss-dev \
+    cups-dev \
+    gconf-dev \
+    libexif-dev \
+    pango-dev \
+    libdrm-dev  \
+    libssp-dev \
+    lua-dev \
+    lua-staticdev \
+    ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'ffmpeg-dev', '', d)} \
+    "
+
+# Add wayland-scanner to SDK (SPEC-945)
+# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
+# wayland-scanner is in nativesdk-wayland-dev !
+# option: add also nativesdk-qtwayland-tools
+TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
+
+TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "