3rd part of the layer/profile rework [2/2]
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
old mode 100644 (file)
new mode 100755 (executable)
index 795ecc0..eac7ea2
@@ -27,6 +27,7 @@ TOOLCHAIN_HOST_TASK += " \
     nativesdk-xz \
     nativesdk-nspr-dev \
     nativesdk-nss-dev \
+    nativesdk-lua \
     "
 
 # required dependencies for Chromium build inside SDK (SPEC-942)
@@ -41,7 +42,9 @@ TOOLCHAIN_TARGET_TASK += " \
     pango-dev \
     libdrm-dev  \
     libssp-dev \
-    ffmpeg-dev \
+    lua-dev \
+    lua-staticdev \
+    ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'ffmpeg-dev', '', d)} \
     "
 
 # Add wayland-scanner to SDK (SPEC-945)
@@ -49,3 +52,5 @@ TOOLCHAIN_TARGET_TASK += " \
 # wayland-scanner is in nativesdk-wayland-dev !
 # option: add also nativesdk-qtwayland-tools
 TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
+
+TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "