Add umock-c to crosssdk
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
old mode 100755 (executable)
new mode 100644 (file)
index 5bb0dc0..35883ae
@@ -8,8 +8,7 @@ require agl-demo-platform.bb
 
 LICENSE = "MIT"
 
-IMAGE_FEATURES_append = " dev-pkgs"
-IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
+require recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc
 
 inherit populate_sdk populate_sdk_qt5
 
@@ -18,14 +17,6 @@ inherit populate_sdk populate_sdk_qt5
 # can failed (randomly).
 addtask do_populate_sdk after do_rootfs
 
-# Add wayland-scanner to SDK (SPEC-945)
-# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
-# wayland-scanner is in nativesdk-wayland-dev !
-# option: add also nativesdk-qtwayland-tools
-TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
-
-TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "
-
 # Add mosquitto to support building the telematics demo application.
 # This is currently required for CI, as it uses agl-demo-platform-crosssdk
 # to build everything. An agenda item has been tabled for the May 2019 F2F
@@ -48,3 +39,7 @@ TOOLCHAIN_TARGET_TASK += "libstdc++-staticdev"
 # AddressSanitizer support to detect use-after-frees along with other
 # memory issue.
 TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
+
+# Add azure-iot-sdk-c to support building agl-service-cloudproxy and
+# other users of Azure sdk.
+TOOLCHAIN_TARGET_TASK += "azure-iot-sdk-c umock-c"