Explicitly add CA certificate package to cluster images
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-cluster-demo-platform.bb
index 385d780..a499246 100644 (file)
@@ -13,7 +13,7 @@ REQUIRED_DISTRO_FEATURES = "wayland"
 # Break out KUKSA.val packages, as demo unit configuration
 # points at KUKSA.val server on the IVI board in full demo
 # builds with the "agl-demo-preload" feature enabled.
-IMAGE_KUKSA_PACKAGES = " \
+KUKSA_DATABROKER_PACKAGES = " \
     packagegroup-agl-kuksa-val-databroker \
     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'packagegroup-agl-kuksa-val-databroker-devel' , '', d)} \
 "
@@ -21,8 +21,9 @@ IMAGE_KUKSA_PACKAGES = " \
 # add packages for cluster demo platform (include demo apps) here
 IMAGE_INSTALL += " \
     packagegroup-agl-cluster-demo-platform \
+    kuksa-certificates-agl-ca \
     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-demo-config", "", d)} \
     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
-    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "${IMAGE_KUKSA_PACKAGES}", d)} \
+    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "${KUKSA_DATABROKER_PACKAGES}", d)} \
     ${@bb.utils.contains("AGL_FEATURES", "AGLCI", "qemu-set-display", "", d)} \
     "