Support systemd services of MOST for CES2017 Demo
[AGL/meta-agl-demo.git] / recipes-kernel / aim-v4l2 / aim-v4l2.bb
index b51fe23..1233696 100644 (file)
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+    # modprobe automatically at boot
+    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+        install -d ${D}${sysconfdir}/modules-load.d
+        echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
+    fi
+}