Remove porter board config
[AGL/meta-agl-demo.git] / recipes-graphics / web-runtime / web-runtime_0.1.bb
index 75077b6..bdfcbec 100644 (file)
@@ -7,9 +7,9 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
 SRC_URI = "\
-       file://web-runtime;md5sum=2245be1e6029b30966f0842e3fee75ea \
-       file://web-runtime.qml;md5sum=922aeae6d596d7c83af01abca266f0df \
-       file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
+    file://web-runtime;md5sum=2245be1e6029b30966f0842e3fee75ea \
+    file://web-runtime.qml;md5sum=922aeae6d596d7c83af01abca266f0df \
+    file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
 "
 
 RDEPENDS_${PN} = "\
@@ -32,11 +32,3 @@ do_install() {
     install -m 0644 ${WORKDIR}/web-runtime.qml ${D}${bindir}/web-runtime.qml
     install -m 0644 ${WORKDIR}/web-runtime-webkit.qml ${D}${bindir}/web-runtime-webkit.qml
 }
-
-do_install_append_rcar-gen2() {
-       # workaround for porter board: force the use of libEGL provided by mesa at runtime
-       # otherwise, the proprietary libEGL is used and a problem then occurs due to a missing EGL function
-    sed -i 's|^\(exec /usr/bin/qt5/qmlscene\)|LD_PRELOAD=/usr/lib/libEGL.so \1|g' ${D}${bindir}/web-runtime
-}
-
-