3rd part of the layer/profile rework [2/2]
[AGL/meta-agl-demo.git] / recipes-graphics / wayland / wayland-ivi-extension / disable-sanitizer-tests.patch
diff --git a/recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch b/recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch
new file mode 100644 (file)
index 0000000..df5d616
--- /dev/null
@@ -0,0 +1,13 @@
+Index: git/ivi-layermanagement-api/test/CMakeLists.txt
+===================================================================
+--- git.orig/ivi-layermanagement-api/test/CMakeLists.txt
++++ git/ivi-layermanagement-api/test/CMakeLists.txt
+@@ -58,7 +58,7 @@ IF(BUILD_ILM_API_TESTS)
+     )
+     SET(GCC_SANITIZER_COMPILE_FLAGS "-fsanitize=address -fsanitize=undefined -fno-sanitize-recover -fstack-protector-all")
+-    SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${GCC_SANITIZER_COMPILE_FLAGS}" )
++    SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}" )
+     SET( CMAKE_CXX_LINK_FLAGS "${CMAKE_CXX_LINK_FLAGS} -static-libasan -static-libubsan" )
+     ADD_EXECUTABLE(${PROJECT_NAME} ${SRC_FILES})