agl-demo: update meta-clang comment
[AGL/meta-agl-demo.git] / recipes-demo / flutter-dashboard / flutter-dashboard_git.bb
index 583eacf..d378df9 100644 (file)
@@ -1,30 +1,24 @@
 SUMMARY = "Flutter Dashboard"
 DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
-
 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard"
-
-BUGTRACKER = "https://github.com/hritik-chouhan/dashboard_for_recipe/issues"
-
 SECTION = "graphics"
 
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
 
-
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard;protocol=https;branch=${AGL_BRANCH} \
-    file://dashboard_config.yaml \
-    "
+           file://dashboard.yaml \
+           file://dashboard.token \
+"
+SRCREV = "2fbe5f8c19863eb4ac013dce5546900592149a26"
 
-SRCREV = "34827b8fdeb3a454cc684a6e8ce4a320ce69517e"
 S = "${WORKDIR}/git"
 
-
 inherit agl-app flutter-app
 
 # flutter-app
 #############
 PUBSPEC_APPNAME = "dashboard_app"
-FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
 FLUTTER_BUILD_ARGS = "bundle -v"
 
 # agl-app
@@ -34,9 +28,15 @@ AGL_APP_ID = "dashboard_app"
 AGL_APP_NAME = "Dashboard"
 
 do_install:append() {
-    install -d ${D}${sysconfdir}/xdg/AGL
-    install -m 0644 ${WORKDIR}/dashboard_config.yaml ${D}${sysconfdir}/xdg/AGL/
+    # VIS authorization token file for KUKSA.val should ideally not
+    # be readable by other users, but currently that's not doable
+    # until a packaging/sandboxing/MAC scheme is (re)implemented or
+    # something like OAuth is plumbed in as an alternative.
+    install -d ${D}${sysconfdir}/xdg/AGL/dashboard
+    install -m 0644 ${WORKDIR}/dashboard.yaml ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/dashboard.token ${D}${sysconfdir}/xdg/AGL/dashboard/
 }
 
 FILES:${PN} += "${sysconfdir}/xdg/AGL"
+RDEPENDS:${PN} += "flutter-auto"