agl-demo: update meta-clang comment
[AGL/meta-agl-demo.git] / recipes-demo / flutter-cluster-dashboard / flutter-cluster-dashboard_git.bb
index 47e19c1..beee700 100644 (file)
@@ -10,62 +10,63 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=0c52b0e4b5f0dbf57ea7d44bebb2e29d"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-instrument-cluster;protocol=https;branch=${AGL_BRANCH} \
     file://flutter-cluster-dashboard.service \
-    file://flutter_cluster_dashboard_on_bg-debug.json \
-    file://flutter_cluster_dashboard_on_bg-profile.json \
-    file://flutter_cluster_dashboard_on_bg-release.json \
-    file://flutter-cluster-dashboard.yaml \
-    file://flutter-cluster-dashboard.yaml.demo \
+    file://flutter_cluster_dashboard_on_bg.json \
+    file://cluster-dashboard.yaml \
+    file://cluster-dashboard.yaml.demo \
+    file://cluster-dashboard.token \
+    file://kvm.conf \
 "
 
 PV = "1.0+git${SRCPV}"
-SRCREV = "e440ec331e7d55cdf2e666d45f63c05571ecc609"
+SRCREV = "5bd594ae8ad92e8e74966c4ad87df83ec8088c2d"
 
 S = "${WORKDIR}/git"
 
 PUBSPEC_APPNAME = "flutter_cluster_dashboard"
 
-FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+inherit flutter-app update-alternatives systemd
 
-OPENROUTE_API_KEY ??= "YOU_NEED_TO_SET_IT_IN_LOCAL_CONF"
+CLUSTER_DEMO_VSS_HOSTNAME ??= "192.168.10.2"
 
-inherit flutter-app update-alternatives
+APP_CONFIG = "flutter_cluster_dashboard_on_bg.json"
 
-APP_CONFIG = "flutter_cluster_dashboard_on_bg-release.json"
-APP_CONFIG:class-runtimedebug = "flutter_cluster_dashboard_on_bg-debug.json"
-APP_CONFIG:class-runtimeprofile = "flutter_cluster_dashboard_on_bg-profile.json"
+SYSTEMD_SERVICE:${PN} = "flutter-cluster-dashboard.service"
 
 do_install:append() {
-    install -D -m 0644 ${WORKDIR}/flutter-cluster-dashboard.service ${D}${systemd_user_unitdir}/flutter-cluster-dashboard.service
-    install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
-    ln -s ../flutter-cluster-dashboard.service ${D}${systemd_user_unitdir}/agl-session.target.wants/flutter-cluster-dashboard.service
+    install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
 
-    install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/default.json
+    install -D -m 0644 ${WORKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
 
-    install -d ${D}${sysconfdir}/xdg/AGL
-    install -m 0644 ${WORKDIR}/flutter-cluster-dashboard.yaml \
-        ${D}${sysconfdir}/xdg/AGL/flutter-cluster-dashboard.yaml.default
-    install -m 0644 ${WORKDIR}/flutter-cluster-dashboard.yaml.demo ${D}${sysconfdir}/xdg/AGL/
+    install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
 
-    install -m 0755 -d ${D}${sysconfdir}/default/ 
-    echo 'OPENROUTE_API_KEY:${OPENROUTE_API_KEY}' >> ${D}${sysconfdir}/default/openroutekey
+    install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
+    install -m 0644 ${WORKDIR}/cluster-dashboard.yaml ${D}${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.default
+    install -m 0644 ${WORKDIR}/cluster-dashboard.yaml.demo ${D}${sysconfdir}/xdg/AGL/
+    sed -i "s/^hostname: .*/hostname: ${CLUSTER_DEMO_VSS_HOSTNAME}/" ${D}${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.demo
+    install -m 0644 ${WORKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
 }
 
-ALTERNATIVE_LINK_NAME[flutter-cluster-dashboard.yaml] = "${sysconfdir}/xdg/AGL/flutter-cluster-dashboard.yaml"
+ALTERNATIVE_LINK_NAME[cluster-dashboard.yaml] = "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml"
 
-FILES:${PN} += "${datadir} ${systemd_user_unitdir} ${sysconfdir}/default/"
+FILES:${PN} += "${datadir} ${sysconfdir}/xdg/AGL"
+
+RDEPENDS:${PN} += "flutter-auto agl-flutter-env liberation-fonts"
 
 PACKAGE_BEFORE_PN += "${PN}-conf ${PN}-conf-demo"
 
-FILES:${PN}-conf += "${sysconfdir}/xdg/AGL/flutter-cluster-dashboard.yaml.default"
+FILES:${PN}-conf += "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.default"
 RDEPENDS:${PN}-conf = "${PN}"
-RPROVIDES:${PN}-conf = "flutter-cluster-dashboard.yaml"
+RPROVIDES:${PN}-conf = "cluster-dashboard.yaml"
 RCONFLICTS:${PN}-conf = "${PN}-conf-demo"
-ALTERNATIVE:${PN}-conf = "flutter-cluster-dashboard.yaml"
-ALTERNATIVE_TARGET_${PN}-conf = "${sysconfdir}/xdg/AGL/flutter-cluster-dashboard.yaml.default"
+ALTERNATIVE:${PN}-conf = "cluster-dashboard.yaml"
+ALTERNATIVE_TARGET_${PN}-conf = "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.default"
 
-FILES:${PN}-conf-demo += "${sysconfdir}/xdg/AGL/flutter-cluster-dashboard.yaml.demo"
+FILES:${PN}-conf-demo += " \
+    ${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.demo \
+    ${systemd_system_unitdir}/flutter-cluster-dashboard.service.d/kvm.conf \
+"
 RDEPENDS:${PN}-conf-demo = "${PN}"
-RPROVIDES:${PN}-conf-demo = "flutter-cluster-dashboard.yaml"
+RPROVIDES:${PN}-conf-demo = "cluster-dashboard.yaml"
 RCONFLICTS:${PN}-conf-demo = "${PN}-conf"
-ALTERNATIVE:${PN}-conf-demo = "flutter-cluster-dashboard.yaml"
-ALTERNATIVE_TARGET_${PN}-conf-demo = "${sysconfdir}/xdg/AGL/flutter-cluster-dashboard.yaml.demo"
+ALTERNATIVE:${PN}-conf-demo = "cluster-dashboard.yaml"
+ALTERNATIVE_TARGET_${PN}-conf-demo = "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.demo"