Update agl-cluster-demo-platform-flutter image
[AGL/meta-agl-demo.git] / recipes-demo / flutter-cluster-dashboard / flutter-cluster-dashboard_git.bb
index 5e90331..44be070 100644 (file)
@@ -30,16 +30,6 @@ APP_CONFIG = "ic_on_bg-release.json"
 APP_CONFIG:class-runtimedebug = "ic_on_bg-debug.json"
 APP_CONFIG:class-runtimeprofile = "ic_on_bg-profile.json"
 
-# To avoid conflicts with the systemd template scheme added via bbappend in
-# meta-agl-demo, package the standalone systemd unit separately.  This is not
-# needed when meta-agl-flutter is used without meta-agl-demo, but that is not
-# going to be the default usecase for most users, so this still allows them to
-# build working agl-image-flutter images in the same build tree.
-#
-# This can be dropped if/when flutter-gallery is no longer packaged as a demo
-# in meta-agl-demo.
-
-#SYSTEMD_SERVICE:${PN}-init = "flutter-cluster-dashboard.service"
 
 do_install:append() {
     install -D -m 0644 ${WORKDIR}/flutter-cluster-dashboard.service ${D}${systemd_user_unitdir}/flutter-cluster-dashboard.service
@@ -49,10 +39,5 @@ do_install:append() {
     install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/default.json
 }
 
-PACKAGE_BEFORE_PN += "${PN}-init"
-
-FILES:${PN} += "${datadir}"
-
-FILES:${PN}-init = "${systemd_user_unitdir}"
 
-RDEPENDS:${PN}-init = "${PN}"
\ No newline at end of file
+FILES:${PN} += "${datadir} ${systemd_user_unitdir}"