Remove systemd user session and clean up packagegroups and images
[AGL/meta-agl-demo.git] / recipes-demo / cluster-receiver / qt-cluster-receiver_git.bb
index 8d8908c..d50e9dd 100644 (file)
@@ -23,18 +23,19 @@ SRCREV  = "b5622ce91307589b03ad5d903214b47ff2277e48"
 
 S  = "${WORKDIR}/git"
 
-inherit cmake_qt5 pkgconfig
+inherit cmake_qt5 pkgconfig systemd
 
 do_install:append() {
     # Only install unit, do not enable it by default
-    install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
+    install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
 }
 
-FILES:${PN} += " ${systemd_user_unitdir}"
-
 RDEPENDS:${PN} += " \
     qtwayland \
     gstreamer1.0-plugins-base \
     gstreamer1.0-plugins-good \
     gstreamer1.0-plugins-bad \
 "
+
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "disable"