Add qt-qrcode recipe for use in settings app
[AGL/meta-agl-demo.git] / recipes-demo-hmi / settings / settings_git.bb
index a018c06..72e0323 100644 (file)
@@ -6,13 +6,21 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2"
+DEPENDS += "libqtappfw qtquickcontrols2 qt-qrcode"
+DEPENDS += "libhomescreen qlibwindowmanager qtvirtualkeyboard"
+
+# runtime dependencies
+RDEPENDS_${PN} += " \
+       qt-qrcode \
+       agl-service-bluetooth \
+       agl-service-network \
+"
 
 inherit qmake5 aglwgt