ondemandnavi: add libqtappfw to DEPENDS
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / ondemandnavi_git.bb
index e15429b..bc82bfc 100644 (file)
@@ -11,6 +11,7 @@ DEPENDS += "qtquickcontrols2 \
             qlibwindowmanager \
             qtlocation \
             qtaglextras \
+            libqtappfw \
 "
 
 PV = "1.0+git${SRCPV}"
@@ -22,10 +23,6 @@ SRCREV = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git"
 
-# Use OSM tiles by default.
-# For mapbox tiles, just comment this out and set an api key.
-EXTRA_QMAKEVARS_CONFIGURE += "ENABLE_OSM=1"
-
 inherit qmake5 aglwgt pkgconfig
 
 do_install_append() {
@@ -35,6 +32,7 @@ do_install_append() {
 
 RDEPENDS_${PN} += "qtlocation \
                    flite \
+                   libqtappfw \
                    openjtalk \
                    gstreamer1.0 \
                    ondemandnavi-config \