Rework mapviewer and mapviewer-demo
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / mapviewer_%.bbappend
index 4e89af0..a559708 100644 (file)
@@ -3,30 +3,23 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
 SRC_URI_append = "\
     file://mapviewer-settings.sh \
     file://mapviewer.service \
-    "
+"
 
 inherit systemd
 
 SYSTEMD_PACKAGES = "${PN}"
 
 do_install_append() {
-    install -d ${D}/usr/AGL/${PN}
-    install -m 0755 ${WORKDIR}/mapviewer-settings.sh ${D}/usr/AGL/${PN}/
+    install -d ${D}${prefix}/AGL/${PN}
+    install -m 0755 ${WORKDIR}/mapviewer-settings.sh ${D}${prefix}/AGL/${PN}/
 
-    # Install systemd unit files
+    # Install systemd unit file
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-        install -d ${D}${systemd_user_unitdir}
-        install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_user_unitdir}/mapviewer.service
+        install -d ${D}${systemd_system_unitdir}
+        install -m 644 ${WORKDIR}/mapviewer.service ${D}${systemd_system_unitdir}/mapviewer.service
     fi
 }
 
-## DO NOT ENABLE 'weston-mapviewer-demo.service' BY DEFAULT
-##
-## This should be enabled/disabled by 'switch_on_mapviewer-demo.sh'/'switch_off_mapviewer-demo.sh'.
-##
-#SYSTEMD_SERVICE_${PN} = "mapviewer.service"
+SYSTEMD_SERVICE_${PN} = "mapviewer.service"
 
-FILES_${PN} += " \
-    ${systemd_user_unitdir}/mapviewer.service \
-    /usr/AGL/mapviewer/ \
-    "
+FILES_${PN} += "${prefix}/AGL/${PN}/"