Use inherit aglwgt in application recipes
[AGL/meta-agl-demo.git] / recipes-demo-hmi / mixer / mixer_git.bb
index c7f30a1..f0ca5d9 100644 (file)
@@ -1,34 +1,18 @@
 SUMMARY     = "Mixer for CES2017 AGL Demonstration"
 DESCRIPTION = "AGL HMI application for control of PulseAudio mixer elements"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
-LICENSE     = "Apache-2.0"
 SECTION     = "apps"
 
-PV = "1.0+git${SRCPV}"
-S  = "${WORKDIR}/git"
-
-inherit qmake5
-
-DEPENDS += "qtquickcontrols2"
-# 'wgtpkg-pack' in af-main-native is required.
-DEPENDS += "af-main-native"
-DEPENDS += "pulseaudio"
-
+LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=http"
 SRCREV  = "${AUTOREV}"
 
-RDEPENDS_${PN} += " \
-    qtmultimedia-qmlplugins \
-    qtquickcontrols2-qmlplugins \
-    "
+PV = "1.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
 
-do_install() {
-    install -d ${D}/usr/AGL/apps
-    install -m 0644 ${B}/package/${PN}.wgt ${D}/usr/AGL/apps/
-}
+inherit qmake5 aglwgt
 
-FILES_${PN} += "/usr/AGL/apps/ \
-    /usr/AGL/apps/${PN} \
-    "
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 pulseaudio"