demo-hmi: mediaplayer: remove unnecessary RDEPENDS
[AGL/meta-agl-demo.git] / recipes-demo-hmi / mediaplayer / mediaplayer_git.bb
index 000f976..9a3690f 100644 (file)
@@ -6,13 +6,20 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 \
+            qtwebsockets \
+            libqtappfw \
+            libhomescreen \
+            qlibwindowmanager \
+"
+
 inherit qmake5 aglwgt
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 qtmultimedia"
+RDEPENDS_${PN} += "agl-service-mediaplayer"