libhomescreen-2017: correct dbus permissions to allow statusbar access
[AGL/meta-agl-demo.git] / recipes-demo-hmi / libhomescreen / libhomescreen-2017_git.bb
index 4ef42ee..b78f2f5 100644 (file)
@@ -12,9 +12,16 @@ DEPENDS = "af-binder json-c"
 
 inherit cmake
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
+          file://org.agl.statusbar.conf \
+         "
 SRCREV = "d97eb6052b7652a42d502e5887bd7acf3fc6d91b"
 S = "${WORKDIR}/git"
 
+do_install_append() {
+       mkdir -p ${D}${sysconfdir}/dbus-1/session.d
+       install -m 0644 ${WORKDIR}/org.agl.statusbar.conf  ${D}${sysconfdir}/dbus-1/session.d
+}
+
 RDEPENDS_${PN} = "agl-service-homescreen-2017"
 PROVIDES += "virtual/libhomescreen"