homescreen: fix missing submodules in SRC_URI
[AGL/meta-agl-demo.git] / recipes-demo-hmi / homescreen / homescreen_git.bb
index a30b235..80d402b 100644 (file)
@@ -1,87 +1,28 @@
 SUMMARY     = "AGL Home Screen Application"
-DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate + HomeScreenAppFrameworkBinderAGL + WindowManager + InputEventManager"
-HOMEPAGE    = "https://wiki.automotivelinux.org/homescreen"
+DESCRIPTION = "AGL Home Screen Application build with recipe method"
+HOMEPAGE    = "http://docs.automotivelinux.org"
 LICENSE     = "Apache-2.0"
 SECTION     = "apps"
-S           = "${WORKDIR}/git/"
-
-BBCLASSEXTEND = " nativesdk"
-
-inherit qmake5 systemd pkgconfig
-DEPENDS = " qtbase "
+LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "\
+        qtbase \
+        qtdeclarative \
+        qtquickcontrols2 \
+        agl-service-homescreen \
+        agl-service-windowmanager \
+        agl-service-weather \
+        libqtappfw \
+        qlibwindowmanager \
+        libhomescreen \
+"
 
-# for HomeScreenAppFrameworkBinderTizen:
-#DEPENDS += " pkgmgr-info aul "
-# for WindowManager:
-DEPENDS += " wayland-ivi-extension "
-# for libhomescreen
-DEPENDS += " glib-2.0 "
-# for sample apps
-DEPENDS += " qtdeclarative qtquickcontrols2 "
+inherit qmake5 systemd pkgconfig aglwgt
 
-LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRCREV  = "${AUTOREV}"
-# PV needs to be modified with SRCPV to work AUTOREV correctly
-PV = "0.0+git${SRCPV}"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git/"
 
 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
-
-do_install() {
-    install -d ${D}/usr/AGL/${PN}
-    install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/usr/AGL/${PN}/
-    install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/usr/AGL/${PN}/
-    install -m 0755 ${B}/SampleHomeScreenInterfaceApp/SampleHomeScreenInterfaceApp ${D}/usr/AGL/${PN}/
-    install -m 0755 ${B}/HomeScreenAppFrameworkBinderAGL/HomeScreenAppFrameworkBinderAGL ${D}/usr/AGL/${PN}/
-    install -m 0755 ${B}/WindowManager/WindowManager ${D}/usr/AGL/${PN}/
-    install -m 0755 ${B}/InputEventManager/InputEventManager ${D}/usr/AGL/${PN}/
-    
-    install -d ${D}${libdir}
-    install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
-    ln -sf ${libdir}/libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
-    ln -sf ${libdir}/libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
-    ln -sf ${libdir}/libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
-
-# kooltux: still some problem with paths inside .pc file
-# error at build time:
-# ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/homescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
-#
-#    install -d ${D}${libdir}/pkgconfig
-#    install -m 0644 ${B}/libhomescreen/pkgconfig/homescreen.pc ${D}${libdir}/pkgconfig/
-
-       install -d ${D}${includedir}
-       install -m 0644 ${S}/libhomescreen/include/libhomescreen.hpp ${D}${includedir}/
-
-    install -d ${D}${systemd_user_unitdir}
-    install -m 0644 ${S}/HomeScreen/conf/HomeScreen.service ${D}${systemd_user_unitdir}
-    install -m 0644 ${S}/HomeScreenAppFrameworkBinderAGL/conf/HomeScreenAppFrameworkBinderAGL.service ${D}${systemd_user_unitdir}
-    install -m 0644 ${S}/InputEventManager/conf/InputEventManager.service ${D}${systemd_user_unitdir}
-    install -m 0644 ${S}/WindowManager/conf/WindowManager.service ${D}${systemd_user_unitdir}
-
-    install -d ${D}${sysconfdir}/systemd/user/default.target.wants
-    ln -sf ${systemd_user_unitdir}/WindowManager.service ${D}${sysconfdir}/systemd/user/default.target.wants
-    ln -sf ${systemd_user_unitdir}/HomeScreen.service ${D}${sysconfdir}/systemd/user/default.target.wants
-}
-
-FILES_${PN} += "/usr/AGL/${PN}/ ${libdir} ${systemd_user_unitdir}"
-FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
-
-
-PACKAGES =+ "libhomescreen libhomescreen-dev libhomescreen-dbg"
-
-FILES_libhomescreen = "\
-       ${libdir}/libhomescreen.so.* \
-"
-FILES_libhomescreen-dev = "\
-       ${includedir}/libhomescreen.hpp \
-       ${libdir}/libhomescreen.so \
-       ${libdir}/pkgconfig/homescreen.pc \
-"
-FILES_libhomescreen-dbg = "\
-       ${libdir}/.debug/libhomescreen.so.* \
-"
-RDEPENDS_libhomescreen-dbg += "${PN}-dbg libhomescreen-dev"
-
-RDEPENDS_${PN}-dev += "libhomescreen-dev"
-