dashboard: update dependencies
[AGL/meta-agl-demo.git] / recipes-demo-hmi / dashboard / dashboard_git.bb
index 2e025eb..822207b 100644 (file)
@@ -6,13 +6,18 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2"
+DEPENDS += "qtquickcontrols2 qttools-native qtaglextras libqtappfw"
 
 inherit qmake5 aglwgt
+
+RDEPENDS_${PN} += " \
+       libqtappfw \
+       agl-service-signal-composer \
+"