alexa-viewer: add recipe and conditionally add to demo image
[AGL/meta-agl-demo.git] / recipes-demo-hmi / alexa-viewer / alexa-viewer_git.bb
diff --git a/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb b/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb
new file mode 100644 (file)
index 0000000..f98704e
--- /dev/null
@@ -0,0 +1,33 @@
+SUMMARY     = "Demo voice capabilities template viewer for Alexa voiceagent"
+DESCRIPTION = "Demo voice capabilities template viewer for Alexa voiceagent"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/alexa-viewer"
+SECTION     = "apps"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+       qtquickcontrols2 \
+       qlibwindowmanager \
+       qlibhomescreen \
+       af-binder \
+       libqtappfw \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/alexa-viewer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+inherit cmake_qt5 aglwgt
+
+OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+
+RDEPENDS_${PN} = " \
+       libqtappfw \
+       libafbwsc \
+       qlibwindowmanager \
+       qlibhomescreen \
+       agl-service-voice-high-capabilities \
+"