Upgrade KUKSA.val components to 0.4.2 release
[AGL/meta-agl-demo.git] / recipes-connectivity / kuksa-val / kuksa-databroker_git.bb
index ac0df73..c35c6d9 100644 (file)
@@ -13,7 +13,8 @@ require kuksa-val.inc
 
 require ${BPN}-crates.inc
 
-SRC_URI += "file://0001-Remove-protobuf-src-usage.patch \
+SRC_URI += "file://0001-Force-older-clap-version-to-build-with-Rust-1.68.patch \
+            file://0002-Remove-protobuf-src-usage.patch \
             file://kuksa-databroker.service \
 "
 
@@ -21,6 +22,9 @@ S = "${WORKDIR}/git"
 
 inherit cargo systemd useradd
 
+# Enable optional VISS support for potential use by e.g. the web apps
+CARGO_BUILD_FLAGS += "--features viss"
+
 SYSTEMD_SERVICE:${PN} = "${BPN}.service"
 
 USERADD_PACKAGES = "${PN}"