Cluster demo support updates
[AGL/meta-agl-demo.git] / recipes-config / cluster-demo-network-config / cluster-demo-network-config_1.0.bb
index a5386b4..ab725c0 100644 (file)
@@ -5,19 +5,29 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
 
 inherit systemd allarch
 
-SRC_URI = "file://cluster-demo-network-conf.service"
+SRC_URI = "file://cluster-demo-network-conf@.service \
+           file://cluster-demo-network-conf.sh \
+"
+
+# Network device for dedicated connection to cluster
+AGL_CLUSTER_NET_DEVICE ?= "eth1"
 
 do_configure[noexec] = "1"
 do_compile[noexec] = "1"
 
 do_install() {
-    # Install cluster demo network configuration service unit
+    # Install helper script
+    install -d ${D}${sbindir}
+    install -m 0755 ${WORKDIR}/cluster-demo-network-conf.sh ${D}${sbindir}/
+
+    # Install service unit
     install -d ${D}${systemd_system_unitdir}
-    install -m 0644 ${WORKDIR}/cluster-demo-network-conf.service ${D}${systemd_system_unitdir}
+    install -m 0644 ${WORKDIR}/cluster-demo-network-conf@.service ${D}${systemd_system_unitdir}/
 
     # Add symlink to network.target.wants
     install -d ${D}${sysconfdir}/systemd/system/network.target.wants
-    ln -s ${systemd_system_unitdir}/cluster-demo-network-conf.service ${D}${sysconfdir}/systemd/system/network.target.wants/
+    ln -s ${systemd_system_unitdir}/cluster-demo-network-conf@.service \
+        ${D}${sysconfdir}/systemd/system/network.target.wants/cluster-demo-network-conf@${AGL_CLUSTER_NET_DEVICE}.service
 }
 
 FILES_${PN} += "${systemd_system_unitdir}"