agl-service-cloudproxy: fix recipe branch/revision
[AGL/meta-agl-demo.git] / recipes-apis / agl-service-cloudproxy / agl-service-cloudproxy_git.bb
index dcfb384..588e86f 100644 (file)
@@ -5,20 +5,19 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=133bb7bd14f18c4f134e819619b3f09a"
 
-inherit cmake aglwgt pkgconfig
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-cloudproxy;protocol=https"
-
-SRCREV = "0cecffd4565b52bd8d200f6bc9f4144f244a6515"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-cloudproxy;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
 
 PV      = "1.0+git${SRCPV}"
 S       = "${WORKDIR}/git/"
 
 DEPENDS = "azure-iot-sdk-c glib-2.0"
 
-RDEPENDS_${PN} += "azure-iot-sdk-c azure-c-shared-utility"
+inherit cmake aglwgt pkgconfig
 
-#azure include files
+# Azure include files
 CXXFLAGS_prepend += "-I${STAGING_INCDIR}/azureiot"
 
+RDEPENDS_${PN} += "azure-iot-sdk-c azure-c-shared-utility"
+
 BBCLASSEXTEND = "native nativesdk"