wam: use gRPC for internal IPC.
[AGL/meta-agl-demo.git] / recipes-wam / wam / wam_git.bb
index cf2d5fa..f1bb666 100644 (file)
@@ -3,20 +3,20 @@ AUTHOR = "Jani Hautakangas <jani.hautakangas@lge.com>"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
-inherit cmake
+inherit cmake pkgconfig
 
-DEPENDS = "glib-2.0 jsoncpp boost chromium79 libhomescreen"
+DEPENDS = "glib-2.0 jsoncpp boost chromium protobuf protobuf-native grpc grpc-native"
 
 EXTRA_OECMAKE = "\
     -DCMAKE_BUILD_TYPE=Release \
     -DCMAKE_INSTALL_PREFIX=${prefix} \
     -DPLATFORM_NAME=${@'${DISTRO}'.upper().replace('-', '_')} \
-    -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium79"
+    -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium"
 
 PR="r0"
 
 PROVIDES += "virtual/webruntime"
-RPROVIDES_${PN} += "virtual/webruntime"
+RPROVIDES:${PN} += "virtual/webruntime"
 
 # Disable some of securit_flags
 # Disable D_FORTIFY_SOURCE=2 and -fstack-protector-strong
@@ -25,38 +25,32 @@ lcl_maybe_fortify = ""
 SECURITY_STACK_PROTECTOR = ""
 
 SRC_URI = "\
-    git://github.com/igalia/${BPN}.git;branch=@43.agl.jellyfish;protocol=https \
-    file://WebAppMgr@.service \
+    git://github.com/igalia/${BPN}.git;branch=@58.agl;protocol=https \
+    file://WebAppMgr.service \
     file://WebAppMgr.env \
-    file://wam-user-setup.sh \
-    file://wam-user-setup@.service \
-    file://trunc-webapp-roles.patch \
 "
 S = "${WORKDIR}/git"
-SRCREV = "a9f18b049d319865514f5f92b248ecdf9c09761d"
+SRCREV = "8ea41f7b59b52ef005f6f932e3335bfd137aa5fa"
 
-do_install_append() {
-    install -d ${D}${sysconfdir}/wam
+PV = "ose58.agl"
+
+do_install:append() {
+    install -v -d ${D}${sysconfdir}/wam
     install -v -m 644 ${S}/files/launch/security_policy.conf ${D}${sysconfdir}/wam/security_policy.conf
-    install -d ${D}${systemd_system_unitdir}
-    install -v -m 644 ${WORKDIR}/WebAppMgr@.service ${D}${systemd_system_unitdir}/WebAppMgr@.service
-    install -d ${D}${sysconfdir}/default/
+    install -v -d ${D}${systemd_user_unitdir}
+    install -v -m 644 ${WORKDIR}/WebAppMgr.service ${D}${systemd_user_unitdir}/WebAppMgr.service
+    install -v -d ${D}${sysconfdir}/default/
     install -v -m 644 ${WORKDIR}/WebAppMgr.env ${D}${sysconfdir}/default/WebAppMgr.env
     ln -snf WebAppMgr ${D}${bindir}/web-runtime
-    install -d ${D}${systemd_system_unitdir}/afm-user-session@.target.wants
-    ln -sf ../WebAppMgr@.service ${D}${systemd_system_unitdir}/afm-user-session@.target.wants/
-    install -d ${D}${libexecdir}/wam/
-    install -v -m 755 ${WORKDIR}/wam-user-setup.sh ${D}${libexecdir}/wam/wam-user-setup.sh
-    install -v -m 644 ${WORKDIR}/wam-user-setup@.service ${D}${systemd_system_unitdir}/wam-user-setup@.service
-    install -d ${D}${systemd_system_unitdir}/user-runtime-dir@.service.wants/
-    ln -sf ../wam-user-setup@.service ${D}${systemd_system_unitdir}/user-runtime-dir@.service.wants/
+    install -v -d ${D}${systemd_user_unitdir}/agl-session.target.wants
+    ln -sf ../WebAppMgr.service ${D}${systemd_user_unitdir}/agl-session.target.wants/
 }
 
-FILES_${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_system_unitdir}"
+FILES:${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_user_unitdir}"
 
-CXXFLAGS_append_agl-devel = " -DAGL_DEVEL"
+CXXFLAGS:append:agl-devel = " -DAGL_DEVEL"
 
-do_install_append_agl-devel() {
+do_install:append:agl-devel() {
     # Enable remote inspector and dev mode
     install -d ${D}${localstatedir}/agl-devel/preferences
     touch ${D}${localstatedir}/agl-devel/preferences/debug_system_apps