wam: use gRPC for internal IPC.
[AGL/meta-agl-demo.git] / recipes-wam / wam / wam_git.bb
index a819d6c..f1bb666 100644 (file)
@@ -3,9 +3,9 @@ AUTHOR = "Jani Hautakangas <jani.hautakangas@lge.com>"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
-inherit cmake
+inherit cmake pkgconfig
 
-DEPENDS = "glib-2.0 jsoncpp boost chromium protobuf protobuf-native libxml2"
+DEPENDS = "glib-2.0 jsoncpp boost chromium protobuf protobuf-native grpc grpc-native"
 
 EXTRA_OECMAKE = "\
     -DCMAKE_BUILD_TYPE=Release \
@@ -25,14 +25,14 @@ lcl_maybe_fortify = ""
 SECURITY_STACK_PROTECTOR = ""
 
 SRC_URI = "\
-    git://github.com/igalia/${BPN}.git;branch=@57.agl;protocol=https \
+    git://github.com/igalia/${BPN}.git;branch=@58.agl;protocol=https \
     file://WebAppMgr.service \
     file://WebAppMgr.env \
 "
 S = "${WORKDIR}/git"
-SRCREV = "692f706b8794b093035915bc401576c55a6e03fc"
+SRCREV = "8ea41f7b59b52ef005f6f932e3335bfd137aa5fa"
 
-PV = "ose57.agl"
+PV = "ose58.agl"
 
 do_install:append() {
     install -v -d ${D}${sysconfdir}/wam