wam: use gRPC for internal IPC.
[AGL/meta-agl-demo.git] / recipes-wam / wam / wam_git.bb
index 81833bb..f1bb666 100644 (file)
@@ -3,9 +3,9 @@ AUTHOR = "Jani Hautakangas <jani.hautakangas@lge.com>"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
-inherit cmake
+inherit cmake pkgconfig
 
-DEPENDS = "glib-2.0 jsoncpp boost chromium protobuf protobuf-native"
+DEPENDS = "glib-2.0 jsoncpp boost chromium protobuf protobuf-native grpc grpc-native"
 
 EXTRA_OECMAKE = "\
     -DCMAKE_BUILD_TYPE=Release \
@@ -25,12 +25,14 @@ lcl_maybe_fortify = ""
 SECURITY_STACK_PROTECTOR = ""
 
 SRC_URI = "\
-    git://github.com/igalia/${BPN}.git;branch=@52.agl.marlin;protocol=https \
+    git://github.com/igalia/${BPN}.git;branch=@58.agl;protocol=https \
     file://WebAppMgr.service \
     file://WebAppMgr.env \
 "
 S = "${WORKDIR}/git"
-SRCREV = "0a0e6c52fa2983f4703ef9fce68b01b631003043"
+SRCREV = "8ea41f7b59b52ef005f6f932e3335bfd137aa5fa"
+
+PV = "ose58.agl"
 
 do_install:append() {
     install -v -d ${D}${sysconfdir}/wam