Convert to new override syntax
[AGL/meta-agl-demo.git] / recipes-wam / wam / wam_git.bb
index ab3a1ae..d7245d9 100644 (file)
@@ -5,18 +5,18 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
 
 inherit cmake
 
-DEPENDS = "glib-2.0 jsoncpp boost chromium79 libhomescreen"
+DEPENDS = "glib-2.0 jsoncpp boost chromium84 libhomescreen"
 
 EXTRA_OECMAKE = "\
     -DCMAKE_BUILD_TYPE=Release \
     -DCMAKE_INSTALL_PREFIX=${prefix} \
     -DPLATFORM_NAME=${@'${DISTRO}'.upper().replace('-', '_')} \
-    -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium79"
+    -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium84"
 
 PR="r0"
 
 PROVIDES += "virtual/webruntime"
-RPROVIDES_${PN} += "virtual/webruntime"
+RPROVIDES:${PN} += "virtual/webruntime"
 
 # Disable some of securit_flags
 # Disable D_FORTIFY_SOURCE=2 and -fstack-protector-strong
@@ -25,15 +25,17 @@ lcl_maybe_fortify = ""
 SECURITY_STACK_PROTECTOR = ""
 
 SRC_URI = "\
-    git://github.com/igalia/${BPN}.git;branch=@43.agl.jellyfish;protocol=https \
+    git://github.com/igalia/${BPN}.git;branch=koi;protocol=https \
     file://WebAppMgr@.service \
     file://WebAppMgr.env \
+    file://wam-user-setup.sh \
+    file://wam-user-setup@.service \
     file://trunc-webapp-roles.patch \
 "
 S = "${WORKDIR}/git"
-SRCREV = "88e9df41cf6dfbcb5d2ea10c769a44e69171a1c3"
+SRCREV = "2a246d2ea79bd335b86942a5579d6de0c9ddce40"
 
-do_install_append() {
+do_install:append() {
     install -d ${D}${sysconfdir}/wam
     install -v -m 644 ${S}/files/launch/security_policy.conf ${D}${sysconfdir}/wam/security_policy.conf
     install -d ${D}${systemd_system_unitdir}
@@ -43,13 +45,18 @@ do_install_append() {
     ln -snf WebAppMgr ${D}${bindir}/web-runtime
     install -d ${D}${systemd_system_unitdir}/afm-user-session@.target.wants
     ln -sf ../WebAppMgr@.service ${D}${systemd_system_unitdir}/afm-user-session@.target.wants/
+    install -d ${D}${libexecdir}/wam/
+    install -v -m 755 ${WORKDIR}/wam-user-setup.sh ${D}${libexecdir}/wam/wam-user-setup.sh
+    install -v -m 644 ${WORKDIR}/wam-user-setup@.service ${D}${systemd_system_unitdir}/wam-user-setup@.service
+    install -d ${D}${systemd_system_unitdir}/user-runtime-dir@.service.wants/
+    ln -sf ../wam-user-setup@.service ${D}${systemd_system_unitdir}/user-runtime-dir@.service.wants/
 }
 
-FILES_${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_system_unitdir}"
+FILES:${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_system_unitdir}"
 
-CXXFLAGS_append_agl-devel = " -DAGL_DEVEL"
+CXXFLAGS:append:agl-devel = " -DAGL_DEVEL"
 
-do_install_append_agl-devel() {
+do_install:append:agl-devel() {
     # Enable remote inspector and dev mode
     install -d ${D}${localstatedir}/agl-devel/preferences
     touch ${D}${localstatedir}/agl-devel/preferences/debug_system_apps