chromium=91.0.4472.114.ose11.agl, wam=ose57.agl
[AGL/meta-agl-demo.git] / recipes-wam / wam / wam_git.bb
index 18ace85..a819d6c 100644 (file)
@@ -5,13 +5,13 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
 
 inherit cmake
 
-DEPENDS = "glib-2.0 jsoncpp boost chromium84 protobuf protobuf-native"
+DEPENDS = "glib-2.0 jsoncpp boost chromium protobuf protobuf-native libxml2"
 
 EXTRA_OECMAKE = "\
     -DCMAKE_BUILD_TYPE=Release \
     -DCMAKE_INSTALL_PREFIX=${prefix} \
     -DPLATFORM_NAME=${@'${DISTRO}'.upper().replace('-', '_')} \
-    -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium84"
+    -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium"
 
 PR="r0"
 
@@ -25,12 +25,14 @@ lcl_maybe_fortify = ""
 SECURITY_STACK_PROTECTOR = ""
 
 SRC_URI = "\
-    git://github.com/igalia/${BPN}.git;branch=marlin;protocol=https \
+    git://github.com/igalia/${BPN}.git;branch=@57.agl;protocol=https \
     file://WebAppMgr.service \
     file://WebAppMgr.env \
 "
 S = "${WORKDIR}/git"
-SRCREV = "478bc7b00d2704d74814c4685c60d62afca50872"
+SRCREV = "692f706b8794b093035915bc401576c55a6e03fc"
+
+PV = "ose57.agl"
 
 do_install:append() {
     install -v -d ${D}${sysconfdir}/wam