[cef] Stop using cros-toolchain
[AGL/meta-agl-demo.git] / recipes-wam / chromium / chromium_git.bb
index 75dc23a..18ff3e6 100644 (file)
@@ -1,18 +1,18 @@
 require chromium.inc
 
 SRC_URI = "\
-    git://github.com/igalia/chromium91;branch=@11.agl;protocol=https;rev=${SRCREV_chromium91};name=chromium91 \
+    git://github.com/igalia/chromium91;branch=@17.agl;protocol=https;rev=${SRCREV_chromium91};name=chromium91 \
     git://github.com/webosose/chromium-v8;branch=@chromium91;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8;protocol=https \
 "
 
 # Needed by catapult
 DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
 
-SRCREV_chromium91 = "d052051b3b8696183322f0d21c911dbbf207a8ab"
+SRCREV_chromium91 = "40fa88380696f62a3644efa6ae4fafda402698f7"
 SRCREV_v8 = "b958ec542dcb086f422a1216a959be38a4cc0339"
 
 CHROMIUM_VERSION = "91.0.4472.114"
-PV_BRANCH_SUFFIX = "ose11.agl"
+PV_BRANCH_SUFFIX = "ose17.agl"
 
 PV = "${CHROMIUM_VERSION}.${PV_BRANCH_SUFFIX}+git"
 
@@ -70,6 +70,7 @@ GN_ARGS:append = " \
 GN_ARGS:append = " \
   is_webos=false \
   is_agl=true \
+  grpc_use_static_linking=true \
 "
 
 # TODO: drop this after we migrate to ubuntu 16.04 or above