[cef] Stop using cros-toolchain
[AGL/meta-agl-demo.git] / recipes-wam / chromium / chromium_git.bb
index 25ed0bb..18ff3e6 100644 (file)
@@ -1,25 +1,21 @@
 require chromium.inc
 
 SRC_URI = "\
-    git://github.com/igalia/chromium87;branch=@10.agl.marlin;protocol=https;rev=${SRCREV_chromium87};name=chromium87 \
-    git://github.com/webosose/chromium-v8;branch=@chromium87;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8;protocol=https \
+    git://github.com/igalia/chromium91;branch=@17.agl;protocol=https;rev=${SRCREV_chromium91};name=chromium91 \
+    git://github.com/webosose/chromium-v8;branch=@chromium91;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8;protocol=https \
 "
 
 # Needed by catapult
 DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
 
-SRCREV_chromium87 = "bc1410d5ad4eca384fa7350410b0df4d3f2bed10"
-SRCREV_v8 = "935065d097cce0090bc858746e6aee0919b222de"
+SRCREV_chromium91 = "40fa88380696f62a3644efa6ae4fafda402698f7"
+SRCREV_v8 = "b958ec542dcb086f422a1216a959be38a4cc0339"
 
-CHROMIUM_VERSION = "87.0.4280.88"
-PV_BRANCH_SUFFIX = "ose10.agl.marlin"
+CHROMIUM_VERSION = "91.0.4472.114"
+PV_BRANCH_SUFFIX = "ose17.agl"
 
 PV = "${CHROMIUM_VERSION}.${PV_BRANCH_SUFFIX}+git"
 
-BROWSER_APPLICATION = "chromium-browser"
-BROWSER_APPLICATION_DIR = "/opt/chromium"
-MKSNAPSHOT_PATH = "v8_snapshot/"
-
 GN_ARGS += "use_gtk=false"
 
 # Disable closure compile
@@ -63,6 +59,10 @@ GN_ARGS += "\
 "
 
 GN_ARGS:append = " \
+  ozone_platform_wayland_external=false \
+  ozone_platform_wayland=true \
+  use_system_libwayland=true \
+  use_system_wayland_scanner=false \
   use_system_minigbm=false \
   use_wayland_gbm=false \
 "
@@ -70,6 +70,7 @@ GN_ARGS:append = " \
 GN_ARGS:append = " \
   is_webos=false \
   is_agl=true \
+  grpc_use_static_linking=true \
 "
 
 # TODO: drop this after we migrate to ubuntu 16.04 or above