chromium*, wam: fix systemd launching from systemd
[AGL/meta-agl-demo.git] / recipes-wam / chromium / chromium84_git.bb
index f5d0732..aaff50b 100644 (file)
@@ -1,24 +1,20 @@
 require chromium.inc
 
 SRC_URI = "\
-    git://github.com/igalia/${PN};branch=koi;protocol=https;rev=${SRCREV_chromium84};name=chromium84 \
-    git://github.com/webosose/chromium-v8;branch=@chromium84;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8 \
-    file://chromium-quiche-invalid-offsetof.patch \
-    file://chromium-skia-no_sanitize.patch \
+    git://github.com/igalia/${PN};branch=marlin;protocol=https;rev=${SRCREV_chromium84};name=chromium84 \
+    git://github.com/webosose/chromium-v8;branch=@chromium84;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8;protocol=https \
 "
 
 # Needed by catapult
 DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
 
-SRCREV_chromium84 = "20b9dd7995c70950e45d66c7c8cc2b2487c90eb6"
+SRCREV_chromium84 = "005a9257d3ba9eb363e19f5a8efc6758924dbf9b"
 SRCREV_v8 = "5c1d89dd2945a10cf7a6a3458050b3177a870b09"
 
 BROWSER_APPLICATION = "chromium84-browser"
 BROWSER_APPLICATION_DIR = "/opt/chromium84"
 MKSNAPSHOT_PATH = "v8_snapshot/"
 
-PACKAGECONFIG_remove="jumbo"
-
 GN_ARGS += "use_gtk=false"
 
 # Disable closure_compile
@@ -59,12 +55,12 @@ GN_ARGS += "\
     use_v8_context_snapshot=false \
 "
 
-GN_ARGS_append = " \
+GN_ARGS:append = " \
   use_system_minigbm=false \
   use_wayland_gbm=false \
 "
 
-GN_ARGS_append = " \
+GN_ARGS:append = " \
   is_webos=false \
   is_agl=true \
 "
@@ -76,5 +72,5 @@ GN_ARGS += "\
 
 # TODO(rzanoni) copied from original recipe to fix qemux86 build.
 # check if it can be removed in the future.
-PACKAGECONFIG_remove_qemux86 = "gstreamer umediaserver neva-media gav neva-webrtc"
+PACKAGECONFIG:remove:qemux86 = "gstreamer umediaserver neva-media gav neva-webrtc"
 #END TODO