SPEC-3723: restructure meta-agl-demo
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-profile-graphical-html5.bb
diff --git a/recipes-platform/packagegroups/packagegroup-agl-profile-graphical-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-profile-graphical-html5.bb
new file mode 100644 (file)
index 0000000..2027501
--- /dev/null
@@ -0,0 +1,23 @@
+SUMMARY = "AGL web runtime profile"
+DESCRIPTION = "The full set of packages required for AGL web runtime"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-agl-profile-graphical-html5 \
+    profile-graphical-html5 \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+    packagegroup-agl-profile-graphical \
+    packagegroup-agl-appfw-html5 \
+"
+
+RDEPENDS_${PN} += "\
+    agl-login-manager \
+    "
+
+RDEPENDS_profile-graphical-html5 = "${PN}"