SPEC-3723: restructure meta-agl-demo
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-profile-cluster.bb
diff --git a/recipes-platform/packagegroups/packagegroup-agl-profile-cluster.bb b/recipes-platform/packagegroups/packagegroup-agl-profile-cluster.bb
new file mode 100644 (file)
index 0000000..c0c6124
--- /dev/null
@@ -0,0 +1,20 @@
+SUMMARY = "The middleware for AGL cluster profile"
+DESCRIPTION = "The set of packages required for AGL Cluster Distribution"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-agl-profile-cluster \
+    profile-cluster \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+    packagegroup-agl-image-boot \
+    packagegroup-agl-core-security \
+    packagegroup-agl-graphical-weston \
+"
+
+RDEPENDS_profile-cluster = "${PN}"