Do not hard-code Flutter version and runtime type
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-profile-cluster-qtcompositor.bb
index 9d54b33..0539ae1 100644 (file)
@@ -2,16 +2,18 @@ SUMMARY = "The middleware for AGL Qt5 based cluster qtcompositor"
 DESCRIPTION = "The set of packages required for AGL Qt5 based Cluster Demo Qtcompositor Distribution"
 LICENSE = "MIT"
 
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
 inherit packagegroup
 
 PACKAGES = "\
     packagegroup-agl-profile-cluster-qtcompositor \
-    profile-cluster-qt5 \
+    profile-cluster-qt5-egl \
     "
 
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
 
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
     packagegroup-agl-image-boot \
     packagegroup-agl-core-security \
     packagegroup-agl-core-connectivity \
@@ -23,14 +25,10 @@ QT_LITE = " \
     qtwayland \
     qtgraphicaleffects-qmlplugins \
     qtsvg-plugins \
-    qtwebsockets \
-    qtwebsockets-qmlplugins \
-    qtcompositor-conf \
 "
 
-RDEPENDS_${PN}_append = " \
+RDEPENDS:${PN}:append = " \
     ${QT_LITE} \
-    agl-login-manager \
 "
 
-RDEPENDS_profile-cluster-qt5 = "${PN}"
+RDEPENDS:profile-cluster-qt5-egl = "${PN}"