3rd part of the layer/profile rework [2/2]
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-ivi-multimedia.bb
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-multimedia.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-multimedia.bb
new file mode 100644 (file)
index 0000000..3b7cf78
--- /dev/null
@@ -0,0 +1,21 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Multimedia Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-agl-ivi-multimedia \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+    gstreamer1.0-plugins-base-meta \
+    gstreamer1.0-plugins-good-meta \
+    lightmediascanner-meta \
+    "
+
+RDEPENDS_${PN} += "\
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', '' , 'virtual/pulseaudio-config', d)} \
+    "