Restore openssh as default in the IVI demo
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo.bb
index 9042de0..b0db220 100644 (file)
@@ -9,12 +9,17 @@ PACKAGES = "\
     packagegroup-agl-demo \
     "
 
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
 
+# Hook for demo platform configuration
+# ATM, only used to disable btwilink module on [MH]3ULCB + Kingfisher by default,
+# setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
+DEMO_ENABLE_BTWILINK ?= ""
+DEMO_PLATFORM_CONF = ""
+DEMO_PLATFORM_CONF:append:ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
 
-RDEPENDS_${PN} += "\
-    packagegroup-agl-appfw \
-    homescreen \
+RDEPENDS:${PN} += "\
+    udisks2 \
     "
 
 # fonts
@@ -23,13 +28,21 @@ TTF_FONTS = " \
     ttf-dejavu-sans \
     ttf-dejavu-sans-mono \
     ttf-dejavu-serif \
+    ttf-noto-emoji-color \
+    source-han-sans-cn-fonts \
+    source-han-sans-jp-fonts \
+    source-han-sans-tw-fonts \
+    source-han-sans-kr-fonts \
     "
 
-RDEPENDS_${PN} += " \
+
+RDEPENDS:${PN} += " \
     linux-firmware-ath9k \
+    linux-firmware-ralink \
     can-utils \
+    cannelloni \
     iproute2 \
-    python-curses \
-    dhcp-client \
+    ${DEMO_PLATFORM_CONF} \
     ${TTF_FONTS} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'webruntime', 'virtual/webruntime', '', d)} \
     "