Add CAN test tools image feature
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo.bb
index 979830a..90283e0 100644 (file)
@@ -9,30 +9,12 @@ PACKAGES = "\
     packagegroup-agl-demo \
     "
 
-ALLOW_EMPTY_${PN} = "1"
-
-SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
-    'packagegroup-agl-smartdevicelink', '', d)}"
-
-# old homescreen package
-HOMESCREEN-OLD = "homescreen"
-# packages from hmi-framework aka homescreen-2017
-HOMESCREEN-NEW = "packagegroup-hmi-framework packagegroup-hmi-framework-dev"
-
-# old audio package
-AUDIO-OLD = "audiomanager"
-# packages from new 4A framework
-AUDIO-NEW = "packagegroup-agl-audio"
-
-RDEPENDS_${PN} += "\
-    libqtappfw \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-hmi-framework', '${HOMESCREEN-NEW}', '${HOMESCREEN-OLD}', d)} \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', '${AUDIO-NEW}', '${AUDIO-OLD}', d)} \
-    udisks \
-    ${SMARTDEVICELINK} \
-    "
-#    packagegroup-agl-appfw \
-#
+# Hook for demo platform configuration
+# ATM, only used to disable btwilink module on [MH]3ULCB + Kingfisher by default,
+# setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
+DEMO_ENABLE_BTWILINK ?= ""
+DEMO_PLATFORM_CONF = ""
+DEMO_PLATFORM_CONF:append:ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
 
 # fonts
 TTF_FONTS = " \
@@ -40,31 +22,18 @@ TTF_FONTS = " \
     ttf-dejavu-sans \
     ttf-dejavu-sans-mono \
     ttf-dejavu-serif \
+    ttf-noto-emoji-color \
     source-han-sans-cn-fonts \
     source-han-sans-jp-fonts \
     source-han-sans-tw-fonts \
+    source-han-sans-kr-fonts \
     "
 
-EXTRA_APPS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'qtwebengine', '', d)}"
-
-#EXTRA_APPS_append = " qtsmarthome cinematicexperience qt5everywheredemo qt5-demo-extrafiles"
-#IMAGE_INSTALL_append = " qtwebengine-examples"
-
-# add support for websocket in Qt and QML
-EXTRA_APPS_append = " qtwebsockets qtwebsockets-qmlplugins"
-PREFERRED_PROVIDER_virtual/webruntime = "web-runtime"
-
-
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
+    udisks2 \
     linux-firmware-ath9k \
-    libsocketcan \
-    canutils \
+    linux-firmware-ralink \
     iproute2 \
-    python-curses \
-    dhcp-client \
+    ${DEMO_PLATFORM_CONF} \
     ${TTF_FONTS} \
-    ${EXTRA_APPS} \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'webruntime', 'virtual/webruntime', '', d)} \
     "
-
-