Prepare master for new framework integration
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
old mode 100755 (executable)
new mode 100644 (file)
index 2cf2b6e..baffeb2
@@ -5,63 +5,48 @@ LICENSE = "MIT"
 
 inherit packagegroup
 
+PROVIDES = "${PACKAGES}"
 PACKAGES = "\
     packagegroup-agl-demo-platform \
+    packagegroup-agl-demo-platform-devel \
     "
 
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
 
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
     packagegroup-agl-image-ivi \
     "
 
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
+    packagegroup-agl-profile-graphical-qt5 \
+    packagegroup-hmi-framework \
     packagegroup-agl-demo \
     "
 
-MOST_DRIVERS = " "
-MOST_DRIVERS_append = " \
-    mocca-usb \
-    most \
-    "
-
-# HVAC dependencies depend on drivers above
-MOST_HVAC = " "
-MOST_HVAC_append = " \
-    ${MOST_DRIVERS} \
-    unicens \
-    vod-server \
-    "
-
-# can-lin is a binary and only for porter :(
-MOST_HVAC_append_porter = " \
-    can-lin \
-    "
 
-# mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
-MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-mapviewer-demo", " mapviewer mapviewer-demo", "",d)}"
+DEMO_UNIT_CONF ?= ""
+# Hook for demo platform configuration
+# ATM used for:
+# 1) Adding udev configuration and scripts for supporting USB attached
+#    I2C devices for RTC and HVAC LED support.
+DEMO_UNIT_CONF += " demo-i2c-udev-conf "
 
-AGL_APPS = " \
-    dashboard \
-    hvac \
-    mediaplayer \
-    mixer \
-    navigation \
-    phone \
-    poiapp \
-    radio \
-    settings \
-    high-level-viwi-service \
-    low-can-demo \
-    "
+# Preload only if agl-demo-preload is set
+DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", " ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
 
-RDEPENDS_${PN}_append = " \
+RDEPENDS:${PN}:append = " \
+    weston-ini-conf \
     qtquickcontrols2-agl \
     qtquickcontrols2-agl-style \
-    linux-firmware-ralink \
-    ${MAPVIEWER} \
-    ${MOST_HVAC} \
-    ${AGL_APPS} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
+    ${DEMO_PRELOAD} \
     "
 
-
+# NOTE: Currently no coverage versions for the application widgets,
+#       they should be added here when available.
+#       Also, the navigation and mixer debug widgets are currently
+#       specified explicitly, as there's no simple way to derive their
+#       names from the virtual/ RPROVIDES at present.
+RDEPENDS:${PN}-devel = " \
+    packagegroup-hmi-framework-devel \
+    "