Convert to new override syntax
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
index a492a2e..6fec1fc 100644 (file)
@@ -5,12 +5,94 @@ LICENSE = "MIT"
 
 inherit packagegroup
 
+PROVIDES = "${PACKAGES}"
 PACKAGES = "\
     packagegroup-agl-demo-platform \
+    packagegroup-agl-demo-platform-devel \
     "
 
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
 
-RDEPENDS_${PN} += "\
-    packagegroup-agl-appfw \
+RDEPENDS:${PN} += "\
+    packagegroup-agl-image-ivi \
+    "
+
+RDEPENDS:${PN} += "\
+    packagegroup-agl-profile-graphical-qt5 \
+    packagegroup-hmi-framework \
+    packagegroup-agl-demo \
+    "
+
+AGL_APPS = " \
+    dashboard \
+    hvac \
+    mediaplayer \
+    virtual/navigation \
+    phone \
+    poiapp \
+    radio \
+    settings \
+    messaging \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'taskmanager' , '', d)} \
+    ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin' , '', d)} \
+    virtual/mixer \
+    virtual/qtwayland-config \
+    "
+
+QTAGLEXTRAS = " libqtappfw"
+
+# add support for websocket in Qt and QML
+QTAGLEXTRAS:append = " qtwebsockets qtwebsockets-qmlplugins"
+#PREFERRED_PROVIDER_virtual/webruntime = "web-runtime"
+
+# Cluster demo support.
+# ATM no cluster map viewer is supported with the older navigation application.
+MAPVIEWER = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "ondemandnavi", "tbtnavi", "",d)}"
+CLUSTER_SUPPORT_PACKAGES = " \
+       ${MAPVIEWER} \
+       cluster-demo-network-config \
+       cluster-lin-bridging-config \
+       cluster-demo-simulator \
+"
+CLUSTER_SUPPORT = "${@bb.utils.contains("AGL_FEATURES", "agl-cluster-demo-support", "${CLUSTER_SUPPORT_PACKAGES}", "",d)}"
+
+DEMO_UNIT_CONF ?= ""
+# Hook for demo platform configuration
+# ATM used for:
+# 1) Adding udev configuration and scripts for supporting USB attached
+#    I2C devices for RTC and HVAC LED support.
+DEMO_UNIT_CONF += " demo-i2c-udev-conf "
+
+# Preload only if agl-demo-preload is set
+DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", " ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
+
+RDEPENDS:${PN}:append = " \
+    weston-ini-conf \
+    qtquickcontrols2-agl \
+    qtquickcontrols2-agl-style \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
+    ${AGL_APPS} \
+    ${QTAGLEXTRAS} \
+    ${CLUSTER_SUPPORT} \
+    ${DEMO_PRELOAD} \
+    "
+
+# NOTE: Currently no coverage versions for the application widgets,
+#       they should be added here when available.
+#       Also, the navigation and mixer debug widgets are currently
+#       specified explicitly, as there's no simple way to derive their
+#       names from the virtual/ RPROVIDES at present.
+RDEPENDS:${PN}-devel = " \
+    packagegroup-hmi-framework-devel \
+    dashboard-dbg \
+    hvac-dbg \
+    mediaplayer-dbg \
+    mixer-dbg \
+    phone-dbg \
+    ondemandnavi-dbg \
+    poiapp-dbg \
+    radio-dbg \
+    settings-dbg \
+    messaging-dbg \
+    taskmanager-dbg \
     "