Convert to new override syntax
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
old mode 100755 (executable)
new mode 100644 (file)
index 4e37405..6fec1fc
@@ -5,64 +5,94 @@ LICENSE = "MIT"
 
 inherit packagegroup
 
+PROVIDES = "${PACKAGES}"
 PACKAGES = "\
     packagegroup-agl-demo-platform \
+    packagegroup-agl-demo-platform-devel \
     "
 
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
 
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
     packagegroup-agl-image-ivi \
     "
 
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
+    packagegroup-agl-profile-graphical-qt5 \
+    packagegroup-hmi-framework \
     packagegroup-agl-demo \
     "
 
-MOST_DRIVERS = " "
-MOST_DRIVERS_append = " \
-    mocca-usb \
-    most \
-    "
-# Don't add MOST support when building for Porter
-MOST_DRIVERS_remove_porter = "most"
-
-# HVAC dependencies depend on drivers above
-MOST_HVAC = " "
-MOST_HVAC_append = " \
-    ${MOST_DRIVERS} \
-    unicens-config \
-    "
-
-# can-lin is a binary and only for porter :(
-MOST_HVAC_append_porter = " \
-    can-lin \
-    "
-
-# mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
-MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-mapviewer-demo", " mapviewer mapviewer-demo", "",d)}"
-
 AGL_APPS = " \
     dashboard \
     hvac \
     mediaplayer \
-    mixer \
-    navigation \
+    virtual/navigation \
     phone \
     poiapp \
     radio \
     settings \
-    high-level-viwi-service \
-    low-can-demo \
+    messaging \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'taskmanager' , '', d)} \
+    ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin' , '', d)} \
+    virtual/mixer \
+    virtual/qtwayland-config \
     "
 
-RDEPENDS_${PN}_append = " \
+QTAGLEXTRAS = " libqtappfw"
+
+# add support for websocket in Qt and QML
+QTAGLEXTRAS:append = " qtwebsockets qtwebsockets-qmlplugins"
+#PREFERRED_PROVIDER_virtual/webruntime = "web-runtime"
+
+# Cluster demo support.
+# ATM no cluster map viewer is supported with the older navigation application.
+MAPVIEWER = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "ondemandnavi", "tbtnavi", "",d)}"
+CLUSTER_SUPPORT_PACKAGES = " \
+       ${MAPVIEWER} \
+       cluster-demo-network-config \
+       cluster-lin-bridging-config \
+       cluster-demo-simulator \
+"
+CLUSTER_SUPPORT = "${@bb.utils.contains("AGL_FEATURES", "agl-cluster-demo-support", "${CLUSTER_SUPPORT_PACKAGES}", "",d)}"
+
+DEMO_UNIT_CONF ?= ""
+# Hook for demo platform configuration
+# ATM used for:
+# 1) Adding udev configuration and scripts for supporting USB attached
+#    I2C devices for RTC and HVAC LED support.
+DEMO_UNIT_CONF += " demo-i2c-udev-conf "
+
+# Preload only if agl-demo-preload is set
+DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", " ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
+
+RDEPENDS:${PN}:append = " \
+    weston-ini-conf \
     qtquickcontrols2-agl \
     qtquickcontrols2-agl-style \
-    linux-firmware-ralink \
-    ${MAPVIEWER} \
-    ${MOST_HVAC} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
     ${AGL_APPS} \
+    ${QTAGLEXTRAS} \
+    ${CLUSTER_SUPPORT} \
+    ${DEMO_PRELOAD} \
     "
 
-
+# NOTE: Currently no coverage versions for the application widgets,
+#       they should be added here when available.
+#       Also, the navigation and mixer debug widgets are currently
+#       specified explicitly, as there's no simple way to derive their
+#       names from the virtual/ RPROVIDES at present.
+RDEPENDS:${PN}-devel = " \
+    packagegroup-hmi-framework-devel \
+    dashboard-dbg \
+    hvac-dbg \
+    mediaplayer-dbg \
+    mixer-dbg \
+    phone-dbg \
+    ondemandnavi-dbg \
+    poiapp-dbg \
+    radio-dbg \
+    settings-dbg \
+    messaging-dbg \
+    taskmanager-dbg \
+    "