navigation: change current application to a RPROVIDES to allow multiple options
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
index 1df09f0..68270ff 100755 (executable)
@@ -24,13 +24,15 @@ MOST_DRIVERS_append = " \
     mocca-usb \
     most \
     "
+# Don't add MOST support when building for Porter
+MOST_DRIVERS_remove_porter = "most"
 
 # HVAC dependencies depend on drivers above
 MOST_HVAC = " "
 MOST_HVAC_append = " \
     ${MOST_DRIVERS} \
-    unicens \
-    vod-server \
+    unicens-config \
+    agl-service-unicens \
     "
 
 # can-lin is a binary and only for porter :(
@@ -39,22 +41,20 @@ MOST_HVAC_append_porter = " \
     "
 
 # mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
-MAPVIEWER = " "
-MAPVIEWER_append_porter = " \
-    mapviewer \
-    mapviewer-demo \
-    "
+MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-mapviewer-demo", " mapviewer mapviewer-demo", "",d)}"
 
 AGL_APPS = " \
     dashboard \
     hvac \
     mediaplayer \
     mixer \
-    navigation \
+    virtual/navigation \
     phone \
     poiapp \
     radio \
     settings \
+    high-level-viwi-service \
+    low-can-demo \
     "
 
 RDEPENDS_${PN}_append = " \