Add updated demo applications back
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
index 0276a70..6ce928f 100644 (file)
@@ -23,30 +23,27 @@ RDEPENDS:${PN} += "\
     packagegroup-agl-demo \
     "
 
+AGL_APPS = " \
+    dashboard \
+    hvac \
+    ondemandnavi \
+    settings \
+    "
 
-DEMO_UNIT_CONF ?= ""
 # Hook for demo platform configuration
 # ATM used for:
 # 1) Adding udev configuration and scripts for supporting USB attached
 #    I2C devices for RTC and HVAC LED support.
-DEMO_UNIT_CONF += " demo-i2c-udev-conf "
+DEMO_UNIT_CONF ?= "demo-i2c-udev-conf"
 
 # Preload only if agl-demo-preload is set
-DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", " ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
+DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "${DEMO_UNIT_CONF}", "",d)}"
 
 RDEPENDS:${PN}:append = " \
     launcher \
     qtquickcontrols2-agl \
     qtquickcontrols2-agl-style \
     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
+    ${AGL_APPS} \
     ${DEMO_PRELOAD} \
     "
-
-# NOTE: Currently no coverage versions for the application widgets,
-#       they should be added here when available.
-#       Also, the navigation and mixer debug widgets are currently
-#       specified explicitly, as there's no simple way to derive their
-#       names from the virtual/ RPROVIDES at present.
-RDEPENDS:${PN}-devel = " \
-    packagegroup-hmi-framework-devel \
-    "